Virtual Machine not working

Hello,
please can someone help me ? My VM got stuck. Here’s how is it:
image
I can’t do anything.

Hey,
that screenshot alone does not tell us much. Please give more info, e.g.

  • operating system
  • Have you enabled virtuliaztion?
  • What have you tried so far?
  • When did the VM stop working properly?

Best,
Tim

can’t you reboot or reopen it…sometimes i also have the same problem…I just close it and restart it again…

Thank you for your responses,
Operating system = windows,
I didn’t touch anything so I don’t think I enabled virtualization at some time, I don’t even know how to do it.
I tried to Uninstall everything and even redownloaded the VM, but I have the same error, it always stops at that point.
It stopped working correctly tonight.
Well, I wish I could give more information.

Jerry

A common fix for windows is:

  • Right click on the Windows logo in the taskbar → open Powershell (Administrator).
    Type “bcdedit /set hypervisorlaunchtype off”, press Enter and restart computer.

Windows has an own virtualization Hyper-V that clashes with the one used in Virtual Box. Sometimes the Hyper-V settings get reset by Windows updates, which can cause the problem you described.

3 Likes

Ant that was the problem! Thanks so much !!! :grin:

2 Likes

I had the same problem and I really admire and wonder how you recognise this kind of problem and find the solution. Could you tell me whether you faced this problem before or how did the solution finding process go?

Over the past few years, several thousand students took Programming 2. With that amount of people, all kinds of problems come up eventually. You’re by far not the first person where the above Windows magic :magic_wand: was the solution. Eventually, you learn to recognize these.

2 Likes

In case there is someone for whom this is not the solution:
I had a similar issue, but only after my first re-start of the VM. The initial launch went flawless. For me the fix was to just give the VM more memory.
To do so, follow these simple steps:

  1. Open Oracle VM VirtualBox Manager
  2. Select “Prog2-2022” VM
  3. Press STRG+S or the orange gear icon which says “Change”
  4. Switch to “System” → “Main board”
  5. By moving the slider with caption “Main memory” you can give it some more memory

For me, this did the trick.

In addition to what @johannes said, I am also using Windows and lost some hours of my live trying to get VMs to run - usually you can find the solutions on the Internet.

2 Likes

Hey,
i have the same issue, but the solution of @Tim.B and @David.Dewes doesn’t work for me. I was in the office hour today. I reeinstalled Oracle VM, i used a new VM but it didnt work either. Are the Log files helpful? Or do you know any other solution?

Best, Tim

Hi Tim,

We have a list of known solutions to (somewhat) common problems here:

Have a look there, and if it still does not work, please start a new thread instead of asking in one that is already marked solved (where we may miss your question).

I think @Tim.Vielhauer got it to work during the OH.

1 Like