Using .. when including headers

Hello,

I had some warnings regarding my includes in vscode telling me to include directories in the names. So I changed:

#include "header.h"

into

#include "../include/header.h"

which solved the warnings.

After a lot of other changes (all committed) and a push I received a failed build on the test server although it builds perfectly fine on my VM.

My theory is that this is because I have the permission to go up a directory when building locally on the VM whereas I don’t have that permission when my program is building on the test server. (Probably for security reasons)

Or is this not an issue?

1 Like

Well, just change it back and ignore the warnings?

To add to this:

There might be more yellow lines in the editor than reported by the style tests.
The cppcheck extension is set to also report some style issues that are explicitly disabled in the cppcheck calls of the tests.

It is a good idea to review them and fix them if there are in your new code.
There might also be some warnings in the provided code.
But for the most part, it was an intentional choice on our side to ignore them.