Style tests fail

Hi,

All my style tests fail and show: “splint binary not available”. When I try to install ./patch.sh, this comes out
image

thanks

Run
sudo pacman -U https://archive.archlinux.org/packages/c/cppcheck/cppcheck-2.7.5-1-x86_64.pkg.tar.zst before running the script.

When I try this, this happens
image

Oh dear. Well, the root cause is that your system is outdated. Unfortunately, due to poor planning on our side (:angry:), the VM does not contain all software necessary to run the style checks.

The solution is to do a full system upgrade. Before you do this, make sure you have saved all necessary files, since this may break the VM, even if that’s unlikely.

Once you have done so, run the following two commands in a terminal:

sudo pacman -Sy archlinux-keyring
sudo pacman -Syu

The first command will be rather quick, the second will likely download several gigabytes and take some time. If any prompts like

<A message/question/hint> [Y/n]?

pop up, press enter. Both commands will likely ask for a password, which is prog2. Remember that you will not see anything when entering the password, just press enter when done.

Once you are done, reboot. If everything still works, congratulations :tada: – you can now run patch.sh

Otherwise, you should reinstall the VM and restore your backups.

Hope this helps
Johannes

1 Like