Problem in git push

Whenever I push my files to git , it isn’t accepting my files named with uppercase letters , for example my file which is name MyBoard.java in my vscode, when I push it to git , it shows me Build fehler, and asks me to rename my file form myboard.java to MyBoard.java but its already with the capital letters. I,ve tried everything, I even deleted my files and again created them but still the issue in unresolved. one of the tutor fixed something today and he told me that there’s a problem in my git setting as it is not accepting Uppercase character files , he did something but again the problem stays the same , Nothing changed .
I,ve been unable to get any results until now and as we have a deadline tomorrow I’m looking for urgent help.
my last idea is that I clone the project from my friend’s id who hasn’t implemented anything as he dropped programming 2 and then I implement everything from beginning and push it with my id , but I’m not sure weather it would work or not , as there might be a problem in my git
Screenshot 2022-07-07 at 17.13.54

The current build error is that you have two files
“Implimentpiece.java” and “implimentpiece.java” with a class Implimentpiece
What you want is:
Only one file Implimentpiece.java with a class Implimentpiece.

How you achieve it:
Delete the file implimentpiece.java properly such that git knows it.
Only deleting it in your folder does not help as git has remembered your file.
git status will also tell you so.
What you should do is:
git rm src/tetris/game/pieces/implimentpiece.java
git commit -m "delete duplicate file implimentpiece.java"
Git will tell you after the git rm (or the English version):

Zum Commit vorgemerkte Änderungen:
  (benutzen Sie "git restore --staged <Datei>..." zum Entfernen aus der Staging-Area)
        gelöscht:       src/tetris/game/pieces/implimentpiece.java

and after the commit:

[master dfd1369] delete duplicate file implimentpiece.java
 1 file changed, 142 deletions(-)
 delete mode 100644 src/tetris/game/pieces/implimentpiece.java

Does this work for you?

I’ll do this and push it and when I’ll get the result at after 22.00 uhh, I’ll get back .
thank you very much

Screenshot 2022-07-07 at 17.29.25
this is what I did . is it okay ? or what shall I do next ?

Yes, you also added a few other changes to the commit.
But this should be okay.
You should now be able to push the correct files.

Screenshot 2022-07-07 at 17.39.44

this deleted my original file also the one with the uppercase character , as I can’t find that now …
what am I supposed to do now

This message would occur if you manually (not with git) delete the file src/tetris/game/pieces/Implimentpiece.java.
You can recover it using the command git tells you:
git restore src/tetris/game/pieces/Implimentpiece.java

yes I got it back . thank you . so now my duplicate file with lowercase letter implementpiece.java is deleted and only Implimentpiece.java is left . right ?
which means everything is fixed ?

Probably yes.
Push your commits to the server.
You then can clone the project in a new location to see exactly what the server sees.
Check there if everything looks correct.

okay thanks , I’ll do that

Screenshot 2022-07-07 at 17.53.27
I cloned it in the vm again after pushing it and now the file seems okay to me as its with uppercase letters. rest I’ll wait for the server results at 22.00uhr and then I’ll see.
thank you very much

image
Every thing seems fine in my vscode , but i still get this now . All the methods are implimented .

Any fixes ?

Hi there!

The method in the Point class that you’re trying to use is called getColumn() , not getColoumn(). If you fix that typo you should be good :slight_smile:

Ahh so stupid of me thankk