Permission denied and exotic error

When I was tring to use"make check" to prove my code, this came out.
Can anyone tell me what happened and how can I fix this?

You are probably experiencing this error:

Thanks for reply.

chown -R prog2:prog2 . has been tried and nothing happend.

I’m afraid that I’m in a different situation, cause I didn’t recieve any other “permission denited” anywhere. As matter of fact , I have successfully used “./” to installs some stuffs and pushed once, they all work in the right way.

also I noticed that there is one check returned “pass”, I’m not sure what this means.

It means that your code is properly formatted.

Put sudo in front of it.

Also, what does ls -la /home/prog2/project3/bin output?

I have tried the format > sudo chown -R prog2:prog2 . the first time it asked me for “password for prog2” which is “prog2” and after that nothing happend.

The problem is solved.
This erro is maybe caused because I create another folder to put all my .c files insteads of put them in src/ . Now after I moved them unter the src/ folder the make check is working correctly.
Thanks for your replying.