Issue with public test

So this is the result I get in my console. The daily test succeded. But for some reason the public one does not

Running test_place_piece_1...
FAILED
============================================================
Expected output:
place returned: 0
Board Size: 16
Board Content: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

============================================================
Actual output was:
place returned: 0
Board Size: 16
Board Content: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
============================================================

The expected output here has a newline at the end.
You probably added the newline by accient.
Check that you did not modify test_place_piece_1.ref. The file should contain exactly three lines.

Note: Please use a short and descriptive title and format your posts for better readability.

1 Like

Yes indeed, this was a Problem and it always added the 4th line. I did remove it now. However my Konsole still says:

Running test_place_piece_1...
FAILED
============================================================
Expected output:
place returned: 0
Board Size: 16
Board Content: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
============================================================
Actual output was:
place returned: 0
Board Size: 16
Board Content: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
============================================================

My programm DID pas the daily test but it does not pass this pub one…

There is also a trailing space in the last line.

1 Like

Ok, you mean in the actual output? How do I even get it to output that… :sweat_smile:

Did you maybe change the ref file of the test by accident? Because this space is present in the official version of this public test which is used on the server.

I asked a friend of mine to send me a raw unmodified file (There I also found a trailing space). However I ran into the same problem as before when I tried deleting the extra line; The Problem is Kate. In the same settings you disable the “new extra line on save”, you also need to disable the “remove trailing spaces”. Otherwise you’ll mess up testfiles (possibly) by simply saving them. You can modify something, modify it to be the old value, but the moment you save with Kate, there is no coming back unless you disable those settings. After I added the trailspace everything went fine.

Reminder: VSCode is also installed on the VM and has appropriate extensions installed for working with MIPS assembly code. VSCode does not do such funny things.

Thanks for the heads up. :slight_smile:

Indeed, this has been an issue for several students.