How to access the repo?

I was asked username and pass to access the repo. what should i input?

The credentials are the same that you use in the CMS. Therefore, use your CMS username and password.

i’ve tried it and it doesn’t work…

2 Likes

Can you explain in more detail what you did?

Did you try cloning it in a command line (with git clone), or did you perhaps try opening the link in your browser? Because the latter will not work.

I tried it to. Cloning the repo by "git clone ‘https://prog2scm.cdl.uni-saarland.de/git/vorlesung/’ "or accessing it via browser is both not working with my cms login.

Are you connected to the university subnet?

1 Like

yes, I’ve conected with the vpn

I also have the same problem here, both cloning and browser give me this error:

fatal: Authentication failed for ‘https://prog2scm.cdl.uni-saarland.de/git/vorlesung/

and I’m connected to the vpn

i was able to clone the project1, but i still have problem with accessing the repo

Then the problem with the project repo probably was that you tried it before it was released (the project started at 16:00).

The one that i mean is the lecture repo. not my project repo

I am connected to the VPN. And the repo is not accessible.

I just cloned the lecture repo and it was no problem. Maybe you could try again and if it is still not working, you could describe exactly what you are doing :slight_smile:

Maybe it is because I am not in the vm but using my own setting, but my shell doesn’ t like the single quotes you used… can you try again without them and tell me if it’ s still not working? So, just entering
git clone https://prog2scm.cdl.uni-saarland.de/git/vorlesung/ <directory>.

Where you should replace <directory> by the name of the directory where you want to store the repo.

best wishes
Lisa :smiley:

Sorry i didn’t wrote it in the forum the way i used it in the Terminal. I wasn’t using any quotes :slight_smile:
I replaced the <directory> too.

I used “git clone https://prog2scm.cdl.uni-saarland.de/git/project1/tim.vielhauer” and “git clone https://prog2scm.cdl.uni-saarland.de/git/vorlesung/project1/”. Then the Git credential manager is asking me for a login and i use my CMS username as well as my password. And then an Authentication failure appears in the terminal.

Thanks

We refreshed the permissions for the lecture repo.
Please try again git clone https://prog2scm.cdl.uni-saarland.de/git/vorlesung/.

For the project, capitalization is important. Your username is Tim.Vielhauer with capital letters at the start of the words.

2 Likes

Now it worked :slight_smile: thank you