Git error: unable to use any git commands in project2

I just finished work on assignment 3.2 in the Seamcarving project and now wanted to make a commit and then push, but instead my git commands were greeted by these error messages.

git_fehler

I was able to use git just fine yesterday, all that changed as far as I can tell is that the green “ref: re…” either wasn’t there yesterday or at least looked differently. All I did between when git last worked and now was working on energy.c, main.c, and looking but not to my knowledge editing index.c, as well as using make check and carve debug.

My project1 git stuff still works normally from what I can tell.

I work via the VM installed on a Windows computer, if that helps.

I was not able to find any other posts on here that mentioned such an issue so I assume this is just me. Is there any way to fix this, or at least find out what is going on?

Thanks that worked. I usually close the VM via the usual shut down, though I worked till quite late in the night yesterday, so it is not impossible that being tired I just clicked the red X of the window or Alt + F4ed.