Git error: problems when committing the project

I just worked on my Project and wanted to commit it, but then i recieved this error message:
image
I had the same problem yesterday, when i tried to commit. I cloned the project again into a new location and thought, that this fixed the problem, because i was able to push my changes. But today i got this same error again.

Here it tells us that internal files in .git are corrupted.
You probably have to clone again, copy, commit, and push.

Have you done something unusual (shutdown the VM from the host, …) or any steps that might help us reproduce the error?

Hello @MichaelG,

some days ago, I’ve got the same issue with my project folder. The fastest solution was, what @Marcel.Ullrich already explained, to backup unsaved changed files in a separate folder, clone it again freshly from the university git server, and then replace the files you downloaded with the just changed files you’ve made a backup from.

This way, all changes should be safe. After that, you can commit and push as you are used to.
If the problem should persist after that, don’t hestiate to ask again :smiley:

Hope that solves your problem.

Hello @David.Dewes,

I followed the Instructions and was able to commit and push now.
Thank you!

1 Like