Fatal error cloning the new project

Hi,

i have sume struggles cloning the newest project onto my machine i would greatly appreciate a reply which explaines why this Error accures.

thank
yikes
you.

Maybe try:

git clone https://prog2scm.cdl.uni-saarland.de/git/project4/Mathieu.S

There is meant to be an empty space between git clone https://prog2scm.cdl.uni-saarland.de/git/project4/Mathieu.S and ./home/prog2/project4.

Best,
Tim

1 Like

Yeah i realized that already but if im not typing the space it randamly spits out that i do not have the permission to enter this directory.

The second part simply specifies a directory the project will get cloned into. If for some reason this one does not work, try out a different directory.

The Problem is, that i cant access the directory where the project is saved. and withoutpermission cloning is rather difficult.

thanks anyways.

I am confused, you need that space and you say if you do not type it, it does not work?

So if i type the space it git replies with the fatal error message that the directory is not found.

if i dont type the space git replies with the fatal error that i do not have permission to acces this directory. So either way it sucks.

You probably are in windows and not the VM.
Therefore, the folder /home/ (and especially /home/prog2) will not exist.

You should just type the command without the folder specifier

git clone https://prog2scm.cdl.uni-saarland.de/git/project4/Mathieu.S

to clone it in the current folder (of your terminal).

3 Likes

That worked thank you very much. Your explanation was really easy to follow and worked immediatly.

Weirdly enough on my home setup the exact same link that i posted earlier worked (obviously also not being in the VM) .

Anyways thanks ^^